Problems with ABS light and loss of power - Suzuki Burgman Forum
 
LinkBack Thread Tools Search this Thread
post #1 of 3 (permalink) Old 03-09-2017, 04:11 PM Thread Starter
New Member
 
Join Date: Nov 2013
Location: London
Posts: 10
Problems with ABS light and loss of power

Hi,

I have a 650 K8, I was riding along and everything seemed to be fine then I noticed the ABS light came on. Shortly afterward the back light on the instrument seemed to become dull and the bike stalled. I have recently had a brand new battery installed so it is not that but it does seem to be linked to power somehow and the battery not charging.

Has anybody experienced a similar problem or have any suggestions?

Thanks for your help.

Howard
howard167@hotmail.co.uk is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 03-09-2017, 05:32 PM
Super Poster
 
Burgmike26's Avatar
 
Join Date: Feb 2017
Location: New Jersey
Posts: 105
My 2002 Goldwing slowly stopped running on a ride in 2015. Eventually it stopped and I pulled over. Had to get it towed home. During the slowdown ABS light came on and other warning lights. Would not turn over when stopped. The alternator had failed at 20,000 miles, original one. Your alternator probably failed too.
Burgmike26 is online now  
post #3 of 3 (permalink) Old 03-09-2017, 06:31 PM
Insane Poster
 
Buffalo's Avatar
 
Join Date: Aug 2005
Location: Texas, Terrell
Posts: 13,526
While an alternator is a possibility, I would first check for a loose battery connection. Then I would check the wires that run from the battery into the wiring harness. These are not the big battery cables but the smaller ones that branch off them. They go about a foot and end in a plug that connects to the wiring harness. Those plugs have been known to melt.
Buffalo is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki Burgman Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Similar Threads
Thread Thread Starter Forum Replies Last Post
Power loss and cutting out HELP! suzride General Discussion 1 08-12-2016 04:43 AM
Sudden power loss downhill? Cholf Daysleeper Burgman 400 (2007+ model) 12 03-08-2016 10:05 AM
Rough idle, Loss of Power jyurong Burgman 650 18 04-14-2010 04:20 AM
FI or F1 light and loss of cvt power. wm23oh Burgman 650 9 04-13-2010 10:45 PM
Sudden loss of power and Paul R Burgman 650 16 12-06-2006 10:02 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome